Display Issues/Screen Tearting/Flickering after update 2.2

CorOS Version: 1.x

Describe your issue:
After I updated to 2.2 and rebooting the display of my quad cortex started to have screen tearing issues. The screen is now very bright, greyish and flickers a lot. Trying to navigate through the UI the icons lag quite a bit and they create a shadow.

I restarted several times and unplugged and replugged the power cabl

Steps to reproduce your issue:

  1. updated to 2.2
  2. rebooted

I have the exact same problem mate have tried contacting nueral but no answer so far. Had to cancel a show because I couldnt use it. Mine happen straight after the 2.2.1 update

I have a show coming up tomorrow…I have mailed the guys at neural and I’ll let you know, if the can come up with a solution. Sometimes the display jumps back to normal but only for a couple of minutes and then it goes back to screen tearing mode

Have you tried a reset via recovery mode? Make sure you have a backup first. Also, clutching at straws here, but I would make sure I did not have anything other than the power plugged in while doing the reset. Definitely unplug anything in the expression pedal inputs as we know there was an issue in the previous firmware with them.

Once you are able to connect with support, they can also walk you through a process to reapply the firmware if necessary. Btw, are you using the stock power supply? If not, I would give that a try as well?

1 Like

Thank you for the response. I’ve just set the QC back to factory settings without any success. unplugged everything except for the power supply (which come with the quad cortex).

To set it back to factory settings you have to reboot the QC and while the Neural logo is on the display you have to hold down the A nd H knob at the same time for 6 secs.

Edit: As long is I turn the volume knob the display colours and lighting looks normal. But as soon as I let go it turns back to screen tearing.

Yeah I’m exactly the same only had it for 2 months hasn’t moved from my desk and always used the power supply that came with it. Tried factory reset and reboot. Happened straight after this bloody update. Mine has flashed back once for a sec then back to screen tearing. Love nueral but $3400 AUD to have this happen after 2 months ? Now cost me a show too :frowning:

Can I also ask do you how long they take to normally get back to you after emailing support ?

Thanks legends

Very sorry to hear this. Any chance you can get in touch with Neural before the show and have them walk you through the process for rolling back the firmware. Going forward they really need a rollback process that can be executed at any time without support’s assistance.

1 Like

No idea how long they take to respond. You might also want to try posting on Neural’s Discord forum asking for help. I know Neural pops in over there from time to time. Might also be an admin who has better access than us to support, that could help out. Also someone might have a helpful suggestion in the interim.

I wonder if this has anything to do with an attempted fix to the volume knob display “jiggling” problem that some users have reported. I think most of them had to send the unit back in for repair. Possible that Neural tried to implement a firmware fix to that issue. Couldn’t help but think of it when @philipp.ferrari mentioned that moving the volume knob appears to temporarily clear the problem. Might be totally unrelated though.

Nah unfortunately show was last night and had to cancel it because I didn’t have any gear lol was gutted ! Praying that nueral support emails back soon to either one of us :slight_smile:

Hi guys, quick info:

The support crew answered within less than a day and I got an update, which unfortunatelly, isn’t very satisfying for this problem in general. They want me to send the QC in and they’re going to have a look at it.

I also have some shows coming up in two weeks and I don’t think that the cortex will find its way back on time…

I’m looking like I’m the same mate except support are dragging there feet it seems and ask me one question every couple of days getting a bit frustrated now tbh good luck mate let me know any update you get bud !