Default Wah Setting after 2.2.0

CorOS Version: 2.2.0

When entering a preset, the expression pedal, after a moment, turns on.
To turn it off, I must toe-down click (on the expression pedal) twice in a row. This is new to 2.2.0 (I JUST updated)

Mission Expression Pedal SP1-ND Connected by two TRS cables.
Expression 2 assigned, set to switch mode.

Repro Steps:

  1. Hybrid mode
  2. Create Preset with any wah model, use a Mission SP1-ND
  3. Save a the preset with the wah OFF and NOT assigned to a switch
  4. Exit preset, re-enter preset*
    *corrected: not scene, but preset

Expected Results:
Wah block is off

Actual Results:
Wah turns on–Is visible activating in the grid shortly after entering preset. Turning it off requires TWO clicks (on expression pedal)

I have tried the following things:

  • I have erased and recreated the wah–assigning the expression pedal params
  • I have tried holding the on/off indicator to see if the scene needs to be set with the block off

Here is one of the effected presets I am using:

I believe what you are describing is related to a known bug that is planned to be resolved in a upcoming hot-fix. Below is the link to a possible workaround:

I’ve had the same issue, I’m hoping they’ll release the fix soon.


Thanks! I’ll give it a shot.

1 Like

I was getting the same. Get out of Hybrid mode. Then go to Stomp mode and see if the Wah is on there. If so turn off. Save. Then go back to Hybrid mode and see if the off state stays.


No luck there.–It’s still erroneous upon entering preset.

Thanks for the suggestion.

Additional notes:

When the QC first turns on, the wah block is in the correct state. The error only occurs upon changing presets.

Going to the settings for Expression 2 (the on/off bit) and interacting with that menu in any way causes the settings menu to close immediately–Faulting to the grid view

Yes my previous solution is not working for me See if you cn duplicate this. Try using your switch then the heel off mode.

My Mission Engineering is connected to EXP 2 per the workaround info and using heel up bypass mode.

Load one of you presets with the wah. Do not touch the wah. If the wah came on turn it off on Control. With the wah off and in the off position. Go to rhe other preset. Pedal should still be in off position. Now rock it so it comes on then foot off and don’t touch it. Go back to the other. Did the wah pedal come on in the on state reproducing the error? Don’t rock it

OK turn the wah off and go back to the other preset. Wah should have stayed in off state. Don’t touch the wah and go back to the other preset. Did the wah remain off?

It seems that the errorfor me only occurs if I switch to the other preset and use the wah rocking the pedal and turning it on. As long as I don’t use it it does not send the PC coomnd that is turning it on.

Dev’s are you reading this. Can you try and duplicate?

OK I set up a simple preset with an amp an a wah pedal. Preset is created with wah using the heel position to bypass. If I load this simple preset and don’t touch the wah just reload the preset again the wah stays in the bypassed state. If I load the preset and move the pedal engaging the wah then reload the wah comes on in the on state.
Trying to determine if it is a swtch or an option or a setting I have done or if this is part of the EXP’s that got broken in the last update. My QC is brand new and of course have been going through and trying everything and I may have caused this and is correctable instead of waiting of the update (which I would think would be fairly simple to compare to the previous release to see what got broke and issue the hotfix that has been promised). I may just do a factory reset since I have not really created anything I need to save and have backed up anyway.

There is certainly something odd going on with the expression pedals since the latest update. Mine was working fine before the update, but I’ve had to remove expression controlled blocks from every one of the presets I use live. I keep reading there’ll be an update soon that’ll fix it. Fingers crossed.


I’m with ya. Really looking forward to that little green dot on the top right when I fire it up.

1 Like

Wonder how many of us are checking twice a day… :rofl::grin:


I believe what is happening is that after QC loads a patch, it is initializing the expression to the minimum value. If that’s the value the pedal had when you saved the patch, then this won’t do anything. But if you’re using a volume pedal, or using toe down for bypass, setting the expression to the minimum will not be what you expect. This is making patch changes in gig situations a pain. I have to sweep the expression pedal from heal to toe on ever patch change to turn the Wah back off. Hope this is fixed soon.


Nope mine is set to heel down and saved that way with the wah off and what the preset expects, As I noted before, if you switch patches and do not touch the wah, which is what is doing it, in that patch and then switch back the fault doesn’t occur. But if you touch the wah at all and then switch to another patch in that other patch the wah will be in the on state even though you left the previous patch with it in the off state.

That may be the intended result. QC 2.2.0 and 2.2.1 seems to be reading the expression pedal position on patch load instead of restoring the position to the saved value. I guess that’s a nice feature, but something we’d need to be aware of.

Unfortunately, 2.2.1 doesn’t seem to be reading the correct value of the expression pedal position on patch load, it always appears to be about 10% too low. This causes heel-toe bypass inverted to not work correctly. Heel-down isn’t impacted because the value is at 0 and can’t go lower.

1 Like

Well I just asked in my support email if in fact the programmers/testers believe that should be the default state and we have to live with it since it was clearly reported before this update. I’m having to get my actual wah pedal out an use it infront of the QC since I can’t have one in my patches in this state. And it’s WORSE after the update since at least if you didn;t use the wah while on one patch and then switch to another the wah stayed in the off state.

I understand people are still having issues with single TRS I/O expression pedals, and I hope they are resolved soon, but…

When it comes to dual TRS I/O pedals, like this Mission SP1-ND, the expected behavior of versions prior to 2.2.0 has been restored with 2.2.1

I am marking this specific defect resolved.

Thank you, SW team.

1 Like

Thanks for the update and feedback!

1 Like

This is the op:
“When entering a preset, the expression pedal, after a moment, turns on.
To turn it off, I must toe-down click (on the expression pedal) twice in a row. This is new to 2.2.0 (I JUST updated)”

Has not been fixed and in fact is worse since before it only came on if you used the pedal and then switched patches. Now it is in the on state ANY time a new patch is loaded.

Got this email from support

"We found an issue where the expression pedal seems to be about 10% lower than the actual position when loading a preset - which makes heel-toe inverted bypass no longer work properly upon preset load. We sent this information to our devs to fix this ASAP.

Apologies for the inconvenience caused.

Best regards,
Neural DSP Support Team"


I was just getting ready to update that I escalated to support directly and another hot fix is on the way. Thanks for the update!