Cortex Control

I have installed the ASIO usb driver first and then I installed the Cortext Control software. I ran both as Admin Windows Control. I started the Cortext Crontrol software while my untit was turned on and hooked up via USB cable to my laptop I am running Win11. When the software boots it gets stuck on ’ Loading Presets…'Will not go any further. Please help.


did you update your QC also?

I had this problem as well, updating the QC and restarting the Cortex Control a few times helped.

I’m also experiencing this. QC was updated to 2.2.0, connected directly to my M1 MacBook Pro running macOS Ventura 13.5.2 via USB B to A cable (using Apple’s multimedia adapter dongle).

Cortex Control is stuck on “Loading Preset…”

I have rebooted both devices, still nothing.

I did see it connect and load up one time, but I tried maximizing the window and it went back to “Loading Preset…”


It’s really questionable. On my Mac Studio (Ventura), Cortex Control either crashes on launch or gets stuck on the “Loading Preset…” screen. On my Macbook Air (Ventura), it’s working fine.

That’s what I call a Beta… :smiley:

1 Like

A lot of people have connection problems using some kind of USB dongle, hub, dock, etc. Including myself. Try using a direct connection trough a single cable. Using a USB B to USB C cable connected directly to the QC and my MacBook air m2 fixed my glitchy cortex control connection. Works like a charm now :innocent:

1 Like

Running on Mac mini M2, OS Sonoma, 2.2.0 update on QC, USB B to USB C cable straight from QC to Mac. No connection issues at all. One bug to report so far with foot switch assignment but otherwise all good.

1 Like

Same issue. NOt using a usb hub and going direct. It just gets stuck on “Loading Preset.” I also tried rebooting both the QC and the control. I am on a mac mini.

Ensure you have updated to the latest CoreOS 2.2.0

1 Like

I have the latest firmware update. I tried a few more times and eventually it was ok. Then later, not ok. Seems it can be hit or miss.

Same here on 2/3 Macs. Hopefully they will solve this issue soon.

Make sure you guys are using the feedback button in Cortex Control. That way support can log the issues and provide resolution in an updated version.

Aye mate, pretty hard to use a feedback button when the app’s not even starting up :wink:

1 Like

True! :smiley:
I should have said where applicable. I should also mention to email as well. The more details they have, hopefully the quicker they can nail down the issue and provide resolution.

Some more findings here, in case they help anyone.

I was previously using the provided USB-B to USB-A cable alone with an Apple dongle to my M1 MacBook Pro. It would get stuck “Loading Presets”.

I read that a USB-B to C cable would work, and I ordered one. Strangely it works, but only 1 orientation. Sometimes I have to flip the cable around (so much for that reversible connector promise).

Then I found if I had any of my thunderbolt hubs connected (which I use for my external displays, Apollo interface, keyboard/mouse, etc) then it would crash. The QC would still be connected directly. Just the mere presence of another hub seemed to cause issues.

I reported this along with device diagnostics to NDSP, so hopefully they are on it.


Same issues here, stuck on “Loading Presets”, so updated to 2.2.2, updated Cortex Control with latest version, tried it with various new cables directly into USB ports on 2 separate Win 11 PC’s (also updated!). Still the same… stuck on “Loading Presets”. I think I’ll wait until a non-beta version comes out!

1 Like

I managed to get cortex control working when I updated to 2.2.0.
Last night I updated again to 2.2.2 and cortex control stuck on loading presets

1 Like

so far I’m running the most up-to-date versions of CorOS and CoCo on an older iMac, with the QC connected via a powered hub and it’s cooperating just fine.

Maybe some of the bugs are related to different computer OSs?

1 Like

Same issue too. OS Monterey. With without hub. Different usb cables etc

Thanks! I updated the CorOS to the latest version. I’m new to this so I did not know it updated via wifi. Then I changed the cable and connected it directly to the PC. No Dongle or adapter was used… and this worked fine. Thanks!

1 Like