Can't log into my account on QC or download updates

CorOS Version: 1.4.1

Describe your issue:
QC has always been connected to the same studio Wi-Fi since I bought it and no changes have been done to that functioning net or router.
QC gives me error when checking for updates. I thought trying to re-login into my account, but once logged out QC doesn’t let me log me in again, getting error “Invalid login credentials. Request ID: (0).”
I don’t know what else to do. I can’t even cloud backup my QC through the app in order to factory reset it. Please help me :frowning:

Steps to reproduce your issue:

  1. Go to setup → My account → “Got Invalid credentials. Request ID: (0)” error even if I put the right ones
  2. Go to setup → Device Options → Device Updates → Got “The update procedure has failed” error.

I have tried the following things:

  • I have tried resetting Wi-Fi settings on QC
  • I have tried rebooting QC and router
  • I have tried uploading Cortex Mobile to v.1.5.0 and successfully logging in with the same credentials I am trying to use on QC
  • I have tried connecting QC to another functioning Wi-Fi, same results
1 Like

Hi @RiccardoB and welcome to the community! Sorry to hear you are having issues with linking your QC. It’s definitely best if you email and they will get you sorted. There are many variables and it sounds like a back end issue with your account which only support would be able to help with unfortunately.

1 Like

Hello, thanks for welcoming me here.
As suggested, I’ve reached for help through support email.

I’ve been replied with quite negligence since I’ve been suggested to try and connect to other functioning Wi-Fi, which is something I tried even before reaching for help and it’s written into my bug report and so I wrote back. I’ve never got replied back from the support.

I tried reaching out on the QC User Group on FB but the same bug report/help request I’ve posted here and through the mail wasn’t accepted by the page’s mods. It’s almost a week now that I can’t use my QC. I’m stuck and freaking out.
Could somebody please help? Or else I’ll be forced to toss the unit. Thanks.

Let me see if I can escalate this for you.

Support says they are in contact with you. Hopefully they get you sorted quickly!