Update wah to new version not allowed

CorOS Version: 2.0.0

Describe your issue:
I have a preset before the 2.0.0 update that has the Bad Horse wah; after upgrading, the icon indicating an update is available is shown yet I can’t update the wah, saying not enough resources to do so. I check the CPU meter and it’s only at 68%.

Steps to reproduce your issue:

  1. Save preset with bad horse legacy version and use up to 68% CPU.
  2. Navigate to another
  3. Try to upgrade the bad horse wah

I expected this to happen:
Able to upgrade the wah to the newest version

I have tried the following things:

  • I have tried restarting the device
  • I could remake the preset from scratch but this is tedious for several presets

You are likely running out of DSP so spread your blocks over additional rows to distribute the load. If you continue to have issues please email support@neuraldsp.com and they will get you sorted quickly.

Does the update to the wah take up significantly more (20%+) CPU usage that it will affect this? I can always re-make the presets or keep the legacy version (live patches so they sound great anyway) but just curious

have you tried deleting the wah then adding back the new version? Sometimes the delete/re-add approach seems to make a difference vs just changing the version in place

Yeah it doesn’t allow me to add the bad horse back in. As a test run, I went to another preset and each bad horse instance seems to only take 3% CPU usage. It doesn’t quite make sense why I can’t insert it if I’m only using 65% CPU.

Is the rest of the preset spread across the lane pairs, to make use of both DSP processors?

I remember just after launch there were some DSP/CPU limitations at first. They worked on optimizing fx and freed up more CPU availability. Maybe this new batch can be optimized further. I’m hearing that some of the amps and the Global EQ can be fairly power-hungry

1 Like

Yeah I split amp & cab to rows 1 & 3 while FX are on rows 2 & 4. Global EQ is off. I’m thinking the bug may be related to the older preset - creating a new preset with a similar setup and using some of the newer presets don’t have this issue when I throw in a wah. Going to play around and diagnose further but wanted to document/report it to see if others are experiencing similar issues after the upgrade.

Also, is it me or has latency been improved? This is based on no measurements or anything scientific, just my non-scientific feel heh.

1 Like

Update: I also tried on a couple new NDSP presets I downloaded, including the new Johns Amp 2. I can’t add a wah to any of the channels and the CPU usage is only 58%.

Seems to be overloading the lane when there’s hungry blocks on them, like the CA2C model.

I think this may have to do with the need for optimization in the QC’s code as you alluded to, and finding a path that has enough CPU left to allow the Wah. Not to discount the possibility of a bug. CorOS 2.0 still has that new code smell. Fresh as a spring day with an occasional whiff of something that needs cleaning up. :grinning:


Yeah something’s definitely strange when you can’t add a wah to a row that only has an amp block in it. I know the CA2C’s a resource hog but still

I sent this to support@neuraldsp.com but wanted to share these in case anyone else was having the same issue(s). This helps explain some of the DSP issues I’ve been running in to: