Running Neural and INVASION in REAPER (popping and unusable)

So I have been having problems with Neural and INVASION GGD at the same time in Reaper…pops and clicks making it completely unusable…That being said I have had zero issues with some other guitar plugs while using invasion. It is only Neural. I am running an intel i9 with 32 gigs of RAM so I am overpowered to say the least…

I was wondering if other users have found a fix? I have fixed it by changing my Requested sample rate @ 4200 and the Block request size ALL THE WAY to 660, while doing this i am able to run stl tones as well as Neural at the same time…Is this is way i should go about things? Does anyone have any other tips??? Any help on this subject is highly appreciated! thanks in advance

-Ephriam Wilkinson IV, Memphis Tennessee

How many instances of the Plugins you need to use in order to reproduce the same result? Are you running them at mono or stereo?

Check our guide for PC optimization, and then analyze your system using Latencymon. Your hardware can be quite powerful, but you also need to consider the real-time performance of your system.

We recommend running your projects at 44.100 Hz / 128 samples. Try to measure the CPU consumption of one instance of the Plugin with those settings using the performance meter inside Reaper. If you wish, you can send your screenshots to

I’ve done everything as far as pc optimization, I’ll run latencymon and get back to you

I might add that this problem is only when I’m running GGD…

Running at mono or stereo doesn’t make a difference.

Looks like it decided to take care of itself? Haha. Went to a/b some products and what do you know! It works great! Crossing my fingers, knock on wood! Lol thank you for the help.

Maybe there was something running on the background? Either way, I’m glad it’s working now.