Reamping DI channel to Quad Cortex in Logic X without latency?

I am trying to reamp a DI channel to the quad cortex in Logic X, using the QC as the audio interface. I send the DI channel to Output USB-5, set a blank channel to Inputs USB 3-4, and I can hear it all fine with no latency. When I record, I get a lot of latency and it’s completely out of time. I’m sure I have done this before and had no problems but for the life of me I can’t figure out what is going wrong! Does anyone else get this issue? If so, how do you get around it?

I run Logic in Low Latency mode. Have you tried that? I know it’s primarily for using Plug-ins that use a lot of DSP/CPU power, but it works in my case with the QC.
You should also probably make sure the Logic project sample rate is set to 48kHz since that’s what the QC is locked to.

You might also want to look at how your monitoring the tracks in the DAW;
" Manage Logic Pro input monitoring latency

Set the sample rate of your project and the I/O buffer size to minimize the amount of latency (delay) you experience while recording audio or playing software instruments.

When recording audio or playing a software instrument in Logic Pro, you might experience a slight delay between playing or singing a note and when you hear the sound from your speakers or headphones. This delay is called input monitoring latency. A variety of factors contribute to input monitoring latency, including:

** The input and output (I/O) buffer size setting in Logic Pro*
** The analog-to-digital (A/D) and digital-to-analog (D/A) conversion processes*
** Any audio interface software that you’re using*
** The sample rate of your project*
** Plug-ins inserted on tracks in your project*

Though you can’t change the amount of input monitoring latency produced by the A/D and D/A conversion processes or by your audio interface’s software, you can set the sample rate of your project and adjust the I/O buffer size to minimize latency. You can also manage latency caused by plug-ins using Low Latency Mode while recording."

I figured this out and it was nothing to do with the QC in the end. It was an adaptive limiter plugin I had on the master - disabled - that was causing the problem. Once I had removed that, all latency was gone. Still not 100% sure I understand why…

Thanks for the reply though.

1 Like