Parallax issue in Cubase 10

Hi, currently i`m working on some demos and tones with the Neural DSP plugins, they sound really awesome!

My last adquisition was Parallax, wich helps to craft a great bass sound in no time. But lately, when i re-open the projects (two that i tested), i get an awful sound, like a ultra saturated signal of my playing, but above digital clipping, with the addition of some graphic bugs in the GUI. At first i thought that it was the first project that got corrupted in some way, so i re-opened a second one, hoping that the issue went away, but the same thing happened.

Then, i tried to remove the plugin and re-inserted on the track, but it kept the same behavior.

Last, after several hours of not knowing what to do, i decided to inspect the components of the plugin, and it seems that the IR section is generating this issue, because after i disabled it, i get a normal signal, tweakable on the multiband processor.

To make my point clearer, I recorded a video with a full-screen capture of my DAW showing this issue. Hope that it can be seen:

BUGPARALLAXCUBASE

Also, this is my setup:

Mac Mini 2018 (6 core, i5, 32 GB RAM)
Mojave 10.14.6 (with the last security update)
Cubase 10
VST version of Parallax
Other plugins in the session:
-Archetype Nolly (with no issues)
-Kontakt 6 Player with GetGood Drums
-Several plugins of many brands

Hello @matiasyv. Thank you for notifying us about this.

I will inform the development team about it to have it fixed as soon as possible.