Is anyone using the Seymour Duncan Power Stage 200?

I have one and the preamp clipping light is on more than half of the time. My out levels on the QC are at 0dB and I’m not even going into the red on the meter. I have to lower the QC level out to -5dB to stop the PS preamp from clipping all the time. Anyone else had this issue?

Are you using XLR outs or OUT3/4 etc? Also, are you using TRS or TS?

Out 4. Running mono. I run from Out 1 direct to FOH via XLR. Out 4 sends everything (no cab) to the Power Amp using TS.

Tried TRS cable from Out 4 to the Power Stage. Didn’t seem to help. Does it need to be TRS on the QC side and TS on the PS side?

It should definitely be TS, not TRS. You should also try the “Send” out with TS, might be better. I am a little suspect though of the outputs which are dual TRS/TS outputs so I’m going to try today using a reamp box between the QC and the amp i.e. TRS to reamp box and TS from box to amp. In relation to your output signal, either your capture or amp model is too loud. If you longpress the output on the grid line you should be able to see the output level which should also give you an indication.

1 Like

I checked the output levels already and they are not even hitting the line or going in to the red. I have to drop the levels down -5dB for the PS not to clip and at the point the output levels on the QC are nowhere close to the line on the meter. I’m starting to think there may be something wrong with the Power Stage.

It could be the power amp, have you contacted their support, tried alternate cables etc?

This is about as high as it gets. The Power Stage is clipping most of the time at this output level.

This is where I have to set it for the QC to not clip the PS preamp.

I tested it with my HX Stomp and I can’t get the PS to clip.

Is there a possibility that the latest update effected the out levels on the QC?

I just can’t think of anything else and I didn’t have this problem pre QC update.

You also have Global EQ enabled which depending on how it’s set could result with some issues. Maybe disable GEQ and re-test. I would also email as well as support for the power amp. I’ll leave this open in case someone with knowledge of that power amp can add any input. There are no known issues with any output levels post 2.0 update (and or prior that I recall).

Tried multiple cables - Same Results
Tried Out 3 - Same Results
Tried using my HX Stomp into the PS - PS doesn’t clip
Next step is to contact Seymour Duncan to see if there are any known issues.

1 Like

The Global EQ is actually bypassed/off. The green light is on in the photo. It may be hard to see.

I have contacted Seymour Duncan.

Thanks for all the help.

1 Like

All sorted. I found 2 other Seymour Duncan PowerStages to test and they did not have the same clipping issue. Talked to SD and my PS will either be repaired or replaced.


Thanks for the update, glad you resolved it! :metal: