Getting around or dealing with latency while playing accurately

I just got the Tim Henson archetype yesterday, and I’m having an incredibly difficult time staying on beat because I can hear my notes coming out just after I play them. It makes me slow down a Lot and its difficult to play with a metronome because everything is just slightly out of sync. How do you get around this? My latency is around 3 MS, and I’m not entirely sure how to get it any lower. At what point does it become unnoticeable? In Tosin Abasi’s most recent Monomyth Playthrough he is using his Archetype and it sounds REALLY tight. Did he just record it without being able to hear the fx? Because that’s really difficult too. And I cant imagine he was playing with any sort of latency due to the ridiculous amount of rhythmic accuracy required to play his music. Help, I do not want to record my music without being able to hear the fx and I also dont want to play with this annoying latency and I have no idea where to start. Thank you

Hey! Send us an email and we can give you some tips and help you troubleshoot.


You won’t get lower than 3ms in literally any digital unit or software. The Axe Fx III, Helix, Eventide H9 - they’re all baseline 3ms in blank presets and only get “worse” as you add blocks and such. You really shouldn’t notice 3ms unless you also had a 0ms signal to compare it to and each were panned hard right and left; even then, you’d be hard pressed to tell which is the “earlier” and which is the “later” signal.

And yes, Abasi’s recorded sound will sound tight because you’re not sitting there feeling the playing and then comparing it to what you’re hearing in the organic loop of “feel.” He’s probably getting about the same latency (3-5ms)

You must have significantly more latency than 3ms if what you’re playing is out of sync to a metronome or legit feels loose. You should be right on or at least indiscernibly close with only 3ms.

I do hope you fins a solution, because I’m also incredibly sensitive to latency and it drives me nuts, so I know what you’re feeling.

1 Like

I’m actually stupid. My latency is 33 ms but I read it as 3 lol, which makes more sense but I still need to fix it. I’ve tried messing around with sample rate/ buffer size and was able to reduce latency to like 24 ms with that method. My pc has 64 gigs of ram and I’m recording through a scarlettrite focus solo 3rd gen and reaper daw. Any suggestion as how to get this lower would be greatly appreciated

Best bet is to get a Mac. I’ve never had any luck getting low latency with PCs. I use a Mac Mini (2018). Perhaps someone who is successful with a PC can chime in. You might also go ask over on thegearpage in the digital & modeling gear sub.

I was having similar issues with other plugins. Make sure you are not using ‘ASIO4ALL’ and instead use the one named after your device, e.g. ‘Solid State Logic ASIO driver’. Leave ‘oversampling’ toggle in normal, disable any inputs not in use, sample rate to 44100, and buffer to 128/256 samples. This fixed my issues as they were too high before.


How are you monitoring? Direct from the interface etc? Some interfaces have what is called a “Z" monitoring selection which helps tremendously. I don’t know if the Focus Solo has that option or not.