Cortex Control stuck at Loading Presets (yes i am an idiot)

edit: I am leaving this as a post of shame, also for those with similar issues needs to be solved. After an hour of troubleshooting i, in fact, realized that something did change on my side - i started using an aftermaker power supply. Yes, its because of that. While device itself seemed to be ok, for some reason, USB usage was poor. Not only Cortex Control didnt launch, QC stopped working normally as an Audio Interface (some jitter appeared). Switching back to original PSU immediately brought everything back to normal. So if you have similar issues - check your power supply.

My apologise to NDSP.

Original irritated post follows:

For months if was working perfectly. Now it does not. Yes i updated, uninstalled, reinstalled, updatet, rebooted, uninstalled, reinstalled, launched as admin, rebootet device, rebooted computer, reinstalled, uninstaled.

No it does not go past “loading presets”.

Now look, kind people. I have work do be done. I pay my bills with music i create. To say that i am infuriated right now, since i need to work, and i cant do it at a pace I used to with tools I used to is really, really, really irritating.

Really, it is exceptionally irritating, that something that worked perfectly stopped with no reason, no action from my side, and no possible way to fix.

You cant even imagine what it takes me not to swear.

Thank you dear Neural DSP for taking care of us, professionals, who rely on your products in our every day work.

Be well.

2 Likes

Thumbs up for 'fessin. :smiley:

1 Like