Ableton MIDI scene changes

I’ve been experiencing an issue with sending MIDI changes to the QC via Ableton. Been in touch with Neural’s support team, but so far they haven’t been able to diagnose the issue. Figured I’d post this here too and see if someone can think of a solution!

Switching scenes in a preset on the QC happens almost instantaneous without any audible artifacts when done with the footswitches on the unit, but when sending a MIDI CC message to it there is a ca. 100ms delay in the scene switching leading to wonky transitions between sounds. We recorded the audio from the QC both ways (switching via footswitch vs switching via MIDI) from the USB out of our X32 and can see that delay compared to the click track we also recorded.

Seeing that the delay only happens when using MIDI to switch I believe the issue is either in how we’re sending MIDI to the QC or how it interprets incoming MIDI. I’ve seen people online using Ableton to send MIDI to the unit without any issues though so I’m suspecting it might be the former.

Our setup is MacbookPro running Ableton → Hyperdrive Thunderbolt 3 → Playaudio 12 → RTP Midi → mioXL → Midi PIN → QC.

Here’s a link to an Ableton session of one of our songs:

Is there anything we’re doing wrong in how we’re sending MIDI from Ableton? Or could there be an issue in how our chain is set up that’s causing that delay?

1 Like

There’s nothing wrong with how you’re sending MIDI, but:

That’s a lot of devices for the MIDI signals to get through to reach the QC. Try experimenting with going directly to the QC (Macbook → Hyperdrive → QC probably) and see if there’s an improvement with the delay.

Also, try setting your buffer size as low as you can (32 or 64 samples) without the computer hiccuping on you.


Thanks for those suggestions man!

I did some troubleshooting yesterday and it seems that the issue is how the QC processes incoming MIDI signal or how scenes change.

First I made an Ableton session that only had a click track and one MIDI track sending scene change CC messages to the QC. Our MacBook is a M1 13inch with an SSD. I first sent those using our chain and had the same exact results in terms of delay on the switch as running our full Ableton session. I was recording the audio output of the QC and our click track so I could see the actual delay time between the two events happening.

I then reduced our buffer size from 128 to 32 with the same exact results happening.

Then I hooked up the QC to the MacBook with a USB cord and unplugged our MIDI chain. With that same barebones Ableton session I had almost the same delay time (I think it was 10ms less, but negligible difference).

As a last step I loaded a new QC preset that had only a mute on the output in one scene and no other blocks. Even then the switch was delayed exactly the same amount. The only difference was that when there were blocks in the scene you could see a little fade in on the audio recording coming from the QC when the scene change happened.

Our solution was to move the MIDI scene change messages 1/16 note earlier (even 1/32 was not enough), but this doesn’t seem like the most elegant solution.

I see a lot of bigger touring acts running Ableton/QC rigs and I’m surprised that this hasn’t come up as an issue yet!

*edit: Also wanted to add that I don’t think we had this issue before the update to CorOS 2. I can’t verify because I don’t have a QC that isn’t updated yet, but as it’s such a noticeable lag in scene changes we would have noticed this if it would have happened before.

Wow, you went full-on Scientific Method with this. Good work.

Unfortunately I don’t know what else to tell you. I’m not using MIDI with QC currently, and even if I did I can’t picture a scenario where I would ever program scene changes mid-song.

Can anyone else speak to this?

Thanks! Wanted to make sure the issue wasn’t somewhere else along the way.

I even went one step further and programmed MIDI switches into a Cubase session, but had the same exact results as doing it from Ableton. Would have been surprised if the DAW was the issue, especially Ableton, but I figured you never know.

I found this post on here from last year - MIDI INPUT LATENCY
where someone expressed a similar issue, but there doesn’t seem to be a solution there. I’m waiting on support to get back to me, have been emailing back and forth but haven’t heard from them in a couple days - I’m guessing because of the weekend.

In this Beato interview with Aaron Marshall he talks about his very low latency setup. Could be pertinent to your situation perhaps…
at about 23:52


Thanks for posting. Great video. Seems to address a ton of questions/comments posted on this forum.

Best closing quote (37:58) from Aaron Marshall- “I see a lot of chatter online in forums and stuff and a lot of people like to nitpick these things and I dont see enough music being made.”

I love hearing the music people are doing using this. We are living awesome times to have so many options.

Thanks for sharing that! His setup is 1:1 what we’re running (Playaudio 12, mio MIDI interface, …), the only difference is that he uses Logic. I’ve tried addressing the QC from both Ableton as well as Cubase with the exact same result. I’ll try Logic as well, but would be surprised if that makes a difference.

We are also using the same setup (with MIDI messages from Ableton) to change plugins on our Apollo interface we’re using for vocal processing and these happen without a delay. I’ve also been troubleshooting our setup with Will from FromStudioToStage and he wasn’t able to find any issues in how we’re sending MIDI messages or with any of the equipment we’re using.

This interview is a year old, which means Aaron was still on CorOS 1.xx - I have a sneaking feeling that something changed on update to CorOS 2 as that is when I first noticed the issue.

I’ve been following up with support at Neural, but they haven’t been responding for the last two weeks.

Wanted to give this a bump and see if anyone else has experienced this issue or found another work around?

Any updates on this? I’m also experiencing latency issues. I’m using the Morningstar MC8 with sensitivity set to 5 (so zero latency normally), yet when I switch the scenes on the Quad Cortex itself it goes immediately, however doing the same via the Morningstar it takes around 100ms or more. Not useable in a live situation. I’m also planning to use ableton cc’s for my solo shows, which was my method when I gigged with the Strymon Iridium. I’m loving the Quad Cortex, but I need it to switch scenes instantly with midi, or else it’s useless. I also cannot get scene B to trigger. I went over the programming on the Morningstar a million times, but it’s perfectly fine and set up exactly ws the other scenes. The other scenes do trigger, just a bit delayed. Hoping for some good news here, because I’ve only had the QC for a week now, am incredibly happy with its possibilities and sounds, but I still need it to function perfectly through midi. Please, Neural, fix this asap.

I’ve read somewhere else (Reddit I think) the comment about the Os 2.0 as well, that with the previous version the issue wasn’t there. I myself have no experience with it, since I updated it upon arrival. Now wishing I didn’t. But then it must be fixable! Os 2.1 please, with midi fixed!

Same issue here with the Hotone Ampero Control. Did not have this problem before updating the OS. Makes me want to go back to my backup but will lose everything I have done after. I guess I can share all my presets on the cloud and roll back and download them again. But I have a gig in a couple days and scared to mess with it. I need this fix asap!

1 Like

Hey! I figured out a way to send MIDI CC earlier via Ableton using the track delay for each MIDI track. -50ms seems to be doing the trick here. I’m not sure if and how you would do that for the Morningstar or the Hotone though!

1 Like

Thanks for the info! Unfortunately, no way to set this in the Hotone.

1 Like

So did this solve the problem? Im getting my QC tomorrow and im not sure if i should update it! Lol

It’s been working great with Ableton - see the comment above, around -50ms track delay does the trick for us - but people with MIDI controler footswitches still seem to be struggling.

Just wanted to jump in here and say I run the same M2 Macbook > PlayAudio12 > Mio set up and experienced crazy latency and also that scenes were jumping all around and turning blocks off before they get to the destination scene… the solution:

  • Midi settings > “Ignore duplicate PC” Turn ON
    -50ms track delay in Ableton

Fixed all my issues!!!