3 x Archetype Plugins: Recurring CPU issue with Live 10.1.15

Hi, I’m on macOS 10.15.5 here and experiencing an extremely troublesome issue with Live 10.1.15 and Neural DSP Archetype plugins.

I’m running a mid-2015 MacBook Retina Pro so nothing amazing but there’s 16GB of RAM and a 2.5 GHz Quad-Core Intel Core i7 processor in there so I’m certainly not underpowered here. My system is a fairly fresh install of Catalina and is running pretty lean generally.

So, when an amp sim plugin is first instantiated on an audio channel in Live (and this is alone) the CPU meter clocks between 16-21% - this is in Normal mode; obviously it would be a bit higher in Oversampling mode…about 29-35%. I understand this is a single-core reference. As time passes the CPU meter creeps up…it does this over minutes until it hits anywhere from 80-115+% and sometimes even crashes Live. Digital garbage commences around 75-80% and it become unusable. Deactivating the post FX will slightly lower the number but doesn’t really help much.

Im operating at 48kHz and my buffer is at 128 though I’ve tried all possible buffers with no success.

Sometimes the plugins come back to normal CPU range. Sometimes they just stay high and crackly.

The only other plugin in my system that behaves like this is another Amp Sim/Fx plugins: Blue Cat Audio Axiom. The behavior is almost identical. For comparison, Helix Native sits and behaves at around 16-20% all the time.

I’m really not sure if this is a Live issue or a plugin issue but would appreciate any advice you may be able to offer. I’ve not been working with these plugins much recently so it’s hard to say this with 100% conviction but I do not remember this kind of behavior ever since day one of the Plini plugin. Since I don’t remember these plugins ever being this unreliable there’s a good chance it may be a problem with Live 10.

It seems to happen with AU, VST2 and VST3 versions equally.

Hope someone here might have some useful advice or a definitive solution to this problem. Thanks.

Hi @lukedoyle. Have you checked if your CPU is thermal throttling? Look for a possible drop in frequency using Intel Power Gadget or similar apps.

You can verify if this only happens with Live trying to replicate the same with another DAW. Check with Reaper for example.

1 Like

While I don’t completely understand what’s going on (despite watching a couple of videos regarding thermal throttling) I note there is a major drop in CPU frequency (clock speed?) when the issue starts to happen. I could reproduce the issue in Logic Pro X and Reaper though Reaper was very stable…it only freaked out when I opened Safari to check this post again. What would be the next step with addressing this issue?

It’s definitely throttling. However, the temperature is not that high.

Make sure you’re connected to the power outlet, then go through the optimization guide. A reset of the SMC could also help.

Hi Gonzalo and thanks for your replies.

It is indeed throttling at around 60 degrees Celsius which makes no sense to me. If it were hitting 100 degrees I would understand – in fact that’s what I understood thermal throttling to be – the CPU’s speed gets ‘throttled back’ to prevent over heating and resulting damage, right?

I had already been through the optimization guide a week ago and most things were common sense regarding power management. The only setting I had not followed the advice on was to “disable handoff between devices” so I’ll deactivate and re-test.

I also reset SMC but in my experience over the years SMC resets are a suggestion that is often made by tech support yet rarely has any actual result. We shall see.

One other thing, and this is definitely not a confirmed solution yet…this CPU has a ‘turbo boost’ function (2.5Ghz can temporarily overclock 3.7GHz). I’m not sure how this affects audio processing when it activates but in the vain hope of finding a solution I found an app to test the effect of disabling the boost function…just incase that was the actual problem.

I couldn’t get the throttling to happen again while turbo boost was deactivated. The CPU limits its operational frequency to a very stable 2.5GHz. I only quickly tested as it was 4 a.m. here so the jury is still out on its efficacy, for now. Is this likely to have some bearing on the problem?

I’m surprised no other Mac users have talked about this kind of issue in any of the audio forums I’ve searched for answers on. Why would it specifically be an issue for me and not others? And why is it specifically limited to Neural and Blue Cat amp/fx sim plugins?

It’s not really common. I guess in this case it’s more noticeable with Plugins that require more processing power to operate.

I would suggest contacting Apple support if you’re unable to fix it. In the screenshot, you can see the frequency drops to 1.0 - 1.1 GHz, which is way below the 2.5 GHz base clock. Also, check if you can replicate it running a CPU benchmark.

I’m unable to reproduce this issue via several CPU benchmark tests.

Only the plugins being used in a DAW trigger the throttling. Interestingly, the standalone versions do not seem to have the same problem.

Also I tried to recreate the problem on the same computer running Mojave from an external bootable drive and I can’t get it to break there either. Possibly a Catalina issue?

My computer is well out of warranty. Apple are not usually interested in helping for these kind of issues on older machines in my experience.

Totally lost here.

The performance with the Standalone will always be different because you’re not limited by how the DAW handles multithreading. Most DAWs will assign one thread per signal path (Ableton is one of them). Maybe the Throttling is getting triggered by just one thread.

OK, so I guess I’ll only be able to use standalone reliably? I haven’t tested standalone much yet…requires further investigation I guess.

But I’m wondering, based on Neural’s suggested minimum CPU specs is my device underpowered?

Intel’s i5-6600 (indicated here as a “minimum requirement”) has a base clock speed of 3.3GHz. The i7-4870HQ in my system has a base clock of 2.5GHz but usually seems to be turbo boosting to approx 3.2GHz when left to it’s own devices.

Not a valid question?

I’m sorry @lukedoyle. I lost track of this thread.

Your specs are not underpowered by any means. But as shown above, the issue is most likely caused by the huge drop in clock speed of your CPU, which is not common at all.

Thanks for replying. I’m yet to find an answer but remain on the search and will post here if I can solve the issue. It’s clearly not a Neural DSP problem and hope I haven’t painted it that way. But the problem renders the plugins unusable.

Yes, please let us know. I hope you can find a solution.

Crazy…I’ve just solved the problem. Complete dumb luck that I figured it out but it’s clearly related to two definite causes and one further possible cause. None of this is documented as far as I know. All triggers are iOS and/or USB peripheral related.

-Running the Luna Display server app. I have a Luna Display dongle on a Thunderbolt 2 Port. It provides a 2nd display on an iOS device. Activating the app triggers throttling in 100% of cases. I’m taking it out forever.

-Zerodebug’s Studiomux Server app. This app enables an iOS device to share bidirectional audio/MIDI over USB with macOS. Simply having the SMUX macOS server software in operation can be a problem (it won’t ever shut down properly and beachballs always) but if you connect an iOS device via USB…bam…throttling starts!!! Apple’s native IDAM will also intermittently trigger the throttling so let’s not just blame Zerodebug.

-I use fairly complex aggregation in Audio MIDI setup for connecting multiple USB audio devices. I removed one USB microphone device from the mix and it may have had an effect on the throttling issue. It certainly improved my aggregate’s overall stability in Live 10 and dropped the latency slightly.

Also, using the GUI in Live 10 will make weird stuff happen. Minimizing it can temporarily solve the issue. But it is only an issue if one of the other triggers is in place. the same moves when the triggers are disabled results in only minor CPU fluctuations and no audio issues.

After all these factors were removed from the macOS equation I could use Archetype Abasi in combination with NI Reaktor and FAS Reverb for over a couple of hours with no CPU issues whatsoever. I’m so very happy to have solved this!!!

That’s great news! I’ll definetly keep this in case someone reports a similar issue. I’ve seen cases where peripherals cause performance problems on Windows-based laptops, but none on macOS systems. Good to know.

Thank you!

Think I jumped to a conclusion here. I was able to trigger throttling by using those mentioned apps.

However, at a time when none of these were in use, the computer again experienced throttling. I guess it runs deeper than I thought.

That’s a bummer. Let us know if you find something else.