Cortex Control freezes while loading

When you create a backup, it is an entire backup with all presets, captures and all settings etc.

1 Like

Thanks for confirming, MP.

1 Like

Hi Pete,
I have the same issue here so if you do find a solution it would be great to hear about it. Likewise if I have any luck I will let you know.

I certainly will, Dan. I need to get off the stick and contact NDSP.

1 Like

I just emailed support. I’ll post an update when I have more info.

I forgot to ask, Dan, is CoCo sticking at the same place for you (Loading preset)?

Problem solved! I emailed Support and they got back to me in less than 20 minutes. As it turns out, I had reinstalled the beta version of Cortex Control. I still don’t understand how the CoCo page’s “Windows” button had downloaded the old version or why it was labeled as v1.0 in my downloads folder. After updating, I went back to the Cortex Control page and tried it again and, this time, the current version downloaded.
They did confirm that the latest driver is needed for CoCo to function (not just for USB recording). Fortunately I’d already installed that (thanks H.O.).

Dan, make sure that you have driver v5.58.0 and Cortex Control v1.0 installed. If it’s still not working for you, contact support for speedy assistance.

Thanks again, everyone!


That’s good news Pete, I’m glad it’s working. I’ll have a look to see if I have done the same thing… fingers crossed snd thanks Pete :+1:.

Thanks for getting back to us on the fix. This will probably assist other users. It might be a good idea for Neural to put the CoCo version on the initial CoCo splash screen. That or have an ‘About’ link or icon that you could click on to check the CoCo version, even if the QC is not connected.

Saying this more for the “next guy’s” benefit and stating the painfully obvious in hindsight I know, but It never hurts to go back to scratch and re-download file(s) when you are having problems with an installation. If for no other reason than it may have been corrupted the first time. Glad you got this issue resolved!

1 Like

Fortunately (or unfortunately) in this case, it was just my powers of observation that were corrupted. :see_no_evil:


Glad you got it resolved and thanks for the update!