2.0.0 Quad Cortex needs an internet connection to finalize the installation

CorOS Version: 2.0.0

Describe your issue:
When I do startup my QC, I see a screen indicating 2.0.0 installation is finalizing. I then see a screen with header: CorOS 2.0.0 installation and body: Quad Cortex needs an internet connection to finalize the installation. I click on the WIFI SETTINGS button and it shows I’m connected. This happens every boot up.

Steps to reproduce your issue:

  1. Reboot, or shutdown and power on unit

I have tried the following things:

  • I have tried unlinking my device, rebooting (error persists), then re-linking (error persists)
  • I have tried disconnecting to wi-fi, then rebooting (error persists)
1 Like

I also have this same error.

It does this every time i restart the device. The OS is updated. I’ve got all the new stuff and it seemingly works while I’m using it. All I have to do is cancel out of the next window.

Here is the reply someone received on the FB group;

That didn’t fix it for me. Still getting this message.

Try the following, worked for me and I had the same message.

I got around it by going to the shutdown screen (power button) and pressing the ‘Reboot’ selection rather than doing a hard shutdown and then restart. That seemed to keep enough of the WiFi processes engaged immediately after reboot to allow the update to complete.


I had this a few times after the update. The wifi signal at the time was around -55db, which has always been OK for normal functions. In the end I disconnected everything, and took the QC to another room where I could place it within inches of a wifi source. I plugged it in, and the update process completed successfully. I took it back to its normal position and plugged everything back in, and it works normally with no wifi problems. I think that the update process tries to complete immediately on booting before the wifi chip has time to establish a stable strong signal, and it doesn’t give you another chance. Wifi on the QC has always been problematic, but the update process seems to need even more signal than usual.

1 Like

If neither of the mentioned fixes work for you, please email. support@neuraldsp.com for additional troubleshooting.

This sounds similar to the problem some people posted on the FB group. Their solution was to disconnect everything (midi cable, usb cable etc.). Power on the QC and it should finalize installation. Then you can reconnect your other cables.

Looks like attached devices may be causing the hang ups.

I would add to this list disconnecting the expression pedal. If connected cables are indeed the source of this issue, the only ones I had connected when I got the WiFi error message during the update finalization process were my USB and expression pedal.

1 Like

So far nothing has worked for me. Have tried everything mentioned in this thread. Email sent to support.

This is what worked for me! Thanks for the suggestion. My guess is the metal chassis makes getting a wifi signal hard so putting it right next to the router seemed to do it.

reboot worked like a charm for me, too.

Make sure you have everything unplugged from the QC, reboot and try again. If you are still having issues, please email support@neuraldsp.com and they will get you sorted quickly.

1 Like