The Plini Problem

First of all, the Archetype Plini is the greatest sounding standalone computer plugin I have ever used. Secondly, I am physically unable to use it and have not recorded a single thing with it since purchasing. Let me explain. When I plug my electric into Plini, pull up my fairy-dust clean tone, and record a take into Logic, it sounds absolutely beautiful. Then two things happen.

Firstly, the waveform never catches, the audio is ALWAYS a straight line with no waveforms. And secondly, as soon as I take Record and Input off, my recorded track goes from beautiful and clean to absolute garbage, underwater, garbled, painfully bad. It is unusable.

I have had this problem on 3 macs. I have not had it with Pro Tools, but I refuse to accept that I need to move DAWs just to use this Neural DSP plugin. The feeling of not knowing why my beautiful takes are not translating into beautiful recordings is so frustrating I can’t even explain. And no it is not software monitoring, no my interface is not doubling the playback or double monitoring the input, I always keep yellow levels (though Plini always plays louder in Logic than the standalone), and I still can’t get a good take.

Please help so I can guitar. Thanks, -William

Hi @dwolivas. Are you using the recommended settings? Try going for 44.1 kHz as your sample rate and 128 as your buffer size.

Did you make sure that the recording delay is set to zero samples? Go to Preferences > Audio > Device and set the recording delay to 0 samples (should be at the middle I think).

Thank you very much for your reply. I have checked my system for every part of your response. I am at 44.1, at 128, with low latency mode on, and I still have the same issue. I will put a video up soon. Also, I just tried the new Corey Wong plugin and I got the exact same problem. It is a plugin problem.

If it happens with both plugins then it shouldn’t be a plugin problem since both Archetypes use a completely different plugin framework. Are you sure the recording delay is set to 0 samples? Also, try disabling low latency mode.

Please send us a video to You can attach screenshots of your audio settings as well.