HELP - Quad Cortex doesn't restart

CorOS Version: 1.0.1

Describe your issue:
I have worked quite normally with my QuadCortex today. For lunch break I had shut it down. And now when trying to restart it, only all lights are going on and off and the display keeps dark. To plug the power cable off and on doesn’t help.
Please advise how to restart. Thanks.

Steps to reproduce your issue:

  1. Step 1
  2. Step 2
  3. Step 3

I have tried the following things:

  • Plug off and on the power cable
  • Touch the sensitive power switch

Are you plugged directly into mains or power strip of some kind? Have you emailed NDSP support on the issue?

I have plugged the mains adapter directly into mains. Yes, and I have had several mails with the Neutraldsp support. Finally the support decided a return and replacement.

1 Like

It happened to me when I accidentally plugged a 9V power adapter (used for Line 6 wireless receiver) into my Quad Cortex. Not enough juce. Maybe your power adapter’s gone bad.

1 Like

I am meanwhile pretty sure that there was a thermal device defect, as the replacement unit doesn’t get that warm as the original one.